AWS Service Outage Impacting PCS Phone Lines

Incident Report for Person Centred Software

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 14:01 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 13:18 BST

Identified

The current global outage of AWS services is impacting our ability to make and receive phone calls. This is being worked on by our provider.
Posted Oct 20, 2025 - 10:53 BST
This incident affected: Aircall Inbound Calls and Aircall Outbound Calls.