Redcrier - Historical Training Records Issue

Incident Report for Person Centred Software

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 15:37 BST

Investigating

We are currently investigating an issue where historical training records are not showing in the completion matrix on Redcrier.
Posted Aug 12, 2026 - 14:48 BST
This incident affected: Redcrier.