Monitor and Care Delivery App Degraded Performance

Incident Report for Person Centred Software

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 12:08 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2026 - 11:38 GMT

Update

Performance on Care Delivery D has degraded. Our engineers are working on the issue
Posted Mar 24, 2026 - 11:05 GMT

Update

All services appear to have returned to normal with the exception of customers using the Care Delivery App on Web Shard C
Posted Mar 24, 2026 - 10:43 GMT

Identified

We are investigating reports of poor performance with Monitor for some customers.
Posted Mar 24, 2026 - 10:28 GMT
This incident affected: mCare (Care Delivery, Monitor).