Performance Issues with mCare on Database Shard B - Affecting 12% of Customers

Incident Report for Person Centred Software

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 10:59 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2026 - 09:31 BST

Investigating

We are aware that some users are currently experiencing slower than usual response times and intermittent difficulties accessing mCare.

We know how important it is that you can rely on our platform to support the people in your care, and we are truly sorry for any disruption this is causing.

Our team has been alerted and is already working to investigate and resolve this as an urgent priority.
Posted Jul 14, 2026 - 08:20 BST
This incident affected: mCare (Care Delivery, Monitor, Relatives Gateway, Action Plans) and mCare Services (API, GP Connect, 3rd Party Integrations, Archive Reporting, Group Reporting, OneLondon Care Records).