mCare Monitor Degraded Performance - Web Shard A - Affecting 16% of Customers

Incident Report for Person Centred Software

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 14:48 BST

Monitoring

Update: We have implemented a fix and are closely monitoring the system to confirm it is performing as expected.

You may find that things are already feeling faster and more stable. If you are still experiencing any issues, please do let us know.

We will confirm full resolution as soon as we are satisfied everything is back to normal. Thank you again for bearing with us.
Posted Apr 29, 2026 - 13:57 BST

Identified

We are aware that some users are currently experiencing slower than usual response times and intermittent difficulties accessing Monitor.

We know how important it is that you can rely on our platform to support the people in your care, and we are truly sorry for any disruption this is causing.

Our team has been alerted and is already working to investigate and resolve this as an urgent priority.
Posted Apr 29, 2026 - 12:55 BST
This incident affected: mCare (Monitor).