Monitor and Care Delivery Degraded Performance - Affecting 6% of Customers

Incident Report for Person Centred Software

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 17:16 BST

Identified

We are aware of poor performance with Monitor and the Care Delivery app for approximately 6% of customers. A fix has been applied and we are waiting for it to improve performance.
Posted Apr 16, 2026 - 16:19 BST
This incident affected: mCare (Care Delivery, Monitor).