Monitor and Care App Degraded Performance

Incident Report for Person Centred Software

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 12:54 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 27, 2026 - 12:38 GMT

Identified

We are investigating reports of poor performance with Monitor and Care App for some customers.
Posted Jan 27, 2026 - 12:15 GMT
This incident affected: mCare (Care Delivery, Monitor, Relatives Gateway) and mCare Services (API, GP Connect, 3rd Party Integrations, Archive Reporting, Group Reporting).