Issue with medications not being dispensed due to incorrectly being marked as 'Not Dispensed (Resident allergy)'

Incident Report for Person Centred Software

Postmortem

Atlas False Positive Allergies on 13/08/25

Summary

On 13.08.2025, Person Centred Software experienced a critical incident that affected Atlas users. We recognise the disruption this caused and want to share a transparent overview of what happened, how we responded, and what we’re doing to prevent recurrence.

Root Cause

After a detailed investigation, we determined that the incident was caused by:

 

  • The deployment of an enhancement of the Allergy functionality caused false positive allergies to be flagged by the system and incorrectly set the allocation of the related items to ND (patient allergic). 
  • False Positive allergies were created for those items with no active ingredient and mapping to no known allergies/non-drug related allergies.

Timeline of Events

Resolution

The issue was resolved by:

  • Changes were implemented in the database code related to the allergy functionality to sever the link between items not containing an active ingredient from  non-related drug allergies or no known allergies.
  • Allergy functionality was restored by 18:00, and functionality has remained working as expected since.

Customer Communication

During the incident, we communicated via Status Page at regular intervals, pharmacies were advised to contact Support if concerned and care homes were directed to contact their pharmacy. We acknowledge the importance of timely, accurate updates and are reviewing how we can improve this further.

Preventative Measures and Next Steps

To reduce the risk of recurrence, we are:

  • Adding additional monitoring to our deployment procedure
  • Introduce enhancements to new functionality testing
  • Conducting additional post deployment checks.
Posted Aug 26, 2025 - 11:36 BST

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 13:25 BST

Update

We have resolved the issue where some medications were incorrectly marked as “Not Dispensed (Resident allergy)”. This will no longer occur.

Care Homes: Please follow your standard booking-in process and remain extra vigilant when reviewing the Outstanding Items Report.
Pharmacies: If you are unsure about changing the dispensing status for any medications that were previously marked in error, please contact our Support Team.

Thank you for your patience and understanding while we worked to resolve this matter.
Posted Aug 14, 2025 - 10:02 BST

Monitoring

A fix has been implemented resolving the issue, medications will no longer be incorrectly marked as "Not Dispensed (Resident allergy)"
Posted Aug 13, 2025 - 19:19 BST

Update

Update on Prescription Item Issue

We are continuing to investigate as a priority, the issue where some prescription items have been incorrectly marked as “Not Dispensed (Resident allergy)” despite no allergy being recorded on the resident’s profile.

Our team is actively working to identify the root cause and will provide a further update first thing in the morning.

Thank you for your patience and understanding as we work to resolve this matter.
Posted Aug 13, 2025 - 16:20 BST

Investigating

We have been made aware of a small number of incidents where a prescription item was incorrectly marked as “Not Dispensed (Resident allergy)”, despite no allergy being recorded on the resident’s profile. This has, in some cases, resulted in the item not being dispensed.

For Care Homes: If you are unsure about a prescription status, please contact your pharmacy in the first instance
For Pharmacies: If you are unsure about the prescription or dispensing status, please contact our Support Team

We are actively investigating the cause and will provide updates as soon as more information is available.
Posted Aug 13, 2025 - 15:04 BST
This incident affected: eMar (CAPA).