Atlas failing to show information from titan correctly. Items not showing as handed out

Incident Report for Person Centred Software

Resolved

We are continuing to investigate this issue.
Posted Jul 08, 2026 - 14:29 BST

Update

We are continuing to investigate this issue.
Posted Jul 08, 2026 - 14:29 BST

Investigating

There is an integration failure with Atlas not correctly showing information from Titan. Our development team are working on investigating this now
Posted Jul 08, 2026 - 13:13 BST
This incident affected: eMar (Titan Integration).