Monitor Degraded Performance - Front End Web Shard G

Incident Report for Person Centred Software

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 16:56 GMT

Identified

We are investigating reports of poor performance with Monitor affecting a limited number of customers on Front End Web Shard G
Posted Mar 23, 2026 - 15:34 GMT
This incident affected: mCare (Monitor).