Atlas Integration timeout issues

Incident Report for Person Centred Software

Resolved

This incident has been resolved.
Posted May 29, 2026 - 16:09 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 29, 2026 - 15:39 BST

Investigating

We are currently investigating an issue with the Atlas Integration API
Posted May 29, 2026 - 15:23 BST
This incident affected: eMar (Atlas Central, Titan Integration).