Resolved: The performance issues affecting the system have now been fully resolved. All services are operating normally.
We are sorry for the disruption this caused during your working day. We know that reliability is essential when you are delivering care, and we do not take that responsibility lightly.
We will be reviewing what happened to help prevent a similar issue in future. If you have any concerns or continue to notice anything unusual, please do not hesitate to contact our Support team.
Posted May 11, 2026 - 12:07 BST
Identified
We are aware that some users are currently experiencing slower than usual response times and intermittent difficulties accessing Monitor.
We know how important it is that you can rely on our platform to support the people in your care, and we are truly sorry for any disruption this is causing.
Our team has been alerted and is already working to investigate and resolve this as an urgent priority.