Monitor Degraded Performance

Incident Report for Person Centred Software

Postmortem

Degraded Performance on Monitor & Care Delivery App on DB Shard I on 5th December 2025

Summary

On Friday 5th December, Person Centred Software experienced a critical incident that affected mCare Monitor and Care Delivery for customers on database shard I. We recognise the disruption this caused and want to share a transparent overview of what happened, how we responded, and what we’re doing to prevent recurrence.

Root Cause

After a detailed investigation, we determined that the incident was caused by:

The synchronisation of a database which was copied for testing coinciding with high usage, which together exceeded the database's connection limits and triggered the outage

Timeline of Events

Resolution

The issue was resolved by:

  • Increased capacity applied to database to allow more connections to handle the demand
  • Cancelled all data transfers in progress until service restored

Customer Communication

During the incident, we communicated via Status Page at regular intervals. We acknowledge the importance of timely, accurate updates and are reviewing how we can improve this further.

Preventative Measures and Next Steps

To reduce the risk of recurrence, we are:

  • Looking to improve database-level monitoring to identify potential issues sooner
  • Continue with weekly capacity reviews to analyse and adjust accordingly
  • Additional monitoring during high impact activities such as data transfers
Posted Dec 17, 2025 - 17:42 GMT

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 13:36 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2025 - 12:44 GMT

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 05, 2025 - 11:51 GMT

Investigating

We are investigating reports of poor performance with Monitor for some customers.
Posted Dec 05, 2025 - 11:23 GMT
This incident affected: mCare (Monitor).